Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 About PyQt5
#1
I haven't solved this problem in about a week. Can you please help me? Picture shows problem.
I tried a lot of solutions, but I didn't get any results.


resimag.com/p1/369c3b4aa80.png
Quote
#2
That's not a link to an image.

Post your code and the error message.
Quote
#3
(venv) E:\Python Derslerim\venv>pip install PyQt5
Collecting PyQt5
Using cached https://files.pythonhosted.org/packages/...4908ec019a
43a970d9eec2a70888b4/PyQt5-5.14.1-5.14.0-cp35.cp36.cp37.cp38-none-win32.whl
Collecting PyQt5-sip<13,>=12.7 (from PyQt5)
Using cached https://files.pythonhosted.org/packages/...176d1528a1
bf6d874bfe22bb2d283c/PyQt5_sip-12.7.0.tar.gz
Installing collected packages: PyQt5-sip, PyQt5
Running setup.py install for PyQt5-sip … \ Subprocess output does not appear to be encoded as
cp1254
error
Complete output from command E:\Yeni\venv\Scripts\python.exe -u -c “import setuptools, tokenize;_
file_=‘C:\Users\SaLoooooo\AppData\Local\Temp\pip-install-mfkn3y39\PyQt5-sip\setup.py’;f=get
attr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(cod
e, file, ‘exec’))” install --record C:\Users\SaLoooooo\AppData\Local\Temp\pip-record-640rh5j1\ins
tall-record.txt --single-version-externally-managed --compile --install-headers E:\Yeni\venv\include
site\python3.8\PyQt5-sip:
running install
running build
running build_ext
building ‘PyQt5.sip’ extension
creating build
creating build\temp.win32-3.8
creating build\temp.win32-3.8\Release
C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\cl.exe /c /nologo /Ox /W3 /GL /DNDEBUG
/MD -IE:\Yeni\venv\include “-IE:\Python 3.x\include” “-IE:\Python 3.x\include” “-IC:\Program Files (
x86)\Microsoft Visual Studio 14.0\VC\INCLUDE” “-IC:\Program Files (x86)\Microsoft Visual Studio 14.0
VC\ATLMFC\INCLUDE” “-IC:\Program Files (x86)\Windows Kits\10\include\10.0.10240.0\ucrt” /Tcapiversion
s.c /Fobuild\temp.win32-3.8\Release\apiversions.obj
apiversions.c
e:\python 3.x\include\pyconfig.h(206): fatal error C1083: i‡erme dosyas\x8d a‡\x8dlam\x8dyor: ‘ba
setsd.h’: No such file or directory
error: command ‘C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\cl.exe’ failed wi
th exit status 2

----------------------------------------
Command "E:\Yeni\venv\Scripts\python.exe -u -c “import setuptools, tokenize;file=‘C:\Users\SaLo
ooooo\AppData\Local\Temp\pip-install-mfkn3y39\PyQt5-sip\setup.py’;f=getattr(tokenize, ‘open’, o
pen)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” i
nstall --record C:\Users\SaLoooooo\AppData\Local\Temp\pip-record-640rh5j1\install-record.txt --single
-version-externally-managed --compile --install-headers E:\Yeni\venv\include\site\python3.8\PyQt5-sip
" failed with error code 1 in C:\Users\SaLoooooo\AppData\Local\Temp\pip-install-mfkn3y39\PyQt5-sip\

İmage
Quote
#4
Okay that was next to useless --- copy/paste your program into the window and wrap it in [.python]Code Goes Here[./python] but remove the "."
Quote
#5
@Denni - OP is trying to install PyQt5, I doubt they have a single line of python code yet
If you can't explain it to a six year old, you don't understand it yourself, Albert Einstein
How to Ask Questions The Smart Way: link and another link
Create MCV example
Debug small programs

Quote
#6
Ah okay I just find that odd as both Python and PyQt5 were a breeze to install for me
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  Huge code problems (buttons(PyQt5),PyQt5 Threads, Windows etc) ZenWoR 0 742 Apr-06-2019, 11:15 PM
Last Post: ZenWoR

Forum Jump:


Users browsing this thread: 1 Guest(s)