Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Cannot Install python-3.7.3-macosx10.6.pkg
#1
I cannot install the latest version of Python (python-3.7.3-macosx10.6.pkg) on Mac OS 10.6.8. The installer throws the following error:

The operation couldn’t be completed. (com.apple.installer.pagecontroller error -1.)

Couldn't open "python-3.7.3-macosx10.6.pkg".

And leaves the following messages in the console log.


5/9/19 4:00:25 PM Installer @(#)PROGRAM:Install PROJECT:Install-596.1
5/9/19 4:00:25 PM Installer @(#)PROGRAM:Installer PROJECT:Installer-430.1
5/9/19 4:00:25 PM Installer Hardware: MacBookPro3,1 @ 2.20 GHz (x 2), 4096 MB RAM
5/9/19 4:00:25 PM Installer Running OS Build: Mac OS X 10.6.8 (10K549)
5/9/19 4:00:25 PM Installer Failed to verify data against certificate.
5/9/19 4:00:25 PM Installer Invalid Distribution File/Package

Any help appreciated.
Quote
#2
Sorry to post a 'me too' but... me too. I could not register on the bug tracker to remind them - the confirmation email never arrives.
Obviously the problem applies to earlier versions as well e.g. 2.7.
Quote
#3
(Jun-21-2019, 10:48 PM)amethyst Wrote: Sorry to post a 'me too' but... me too. I could not register on the bug tracker to remind them - the confirmation email never arrives.
Obviously the problem applies to earlier versions as well e.g. 2.7.

LOL. If you are still on 10.6 like me, your browsers are probably waaay out of date. I forget what I used to register. Try (ugh) Chrome. I managed to get 3.7.0 (v3.7.0:1bf9cc5093 to load.
Quote
#4
No, I tried registering with an iPad too.
Thanks for the tip, I got 3.7 to install.
But now numpy won't import :(
Quote
#5
(Jun-22-2019, 09:25 PM)amethyst Wrote: No, I tried registering with an iPad too.
Thanks for the tip, I got 3.7 to install.
But now numpy won't import :(

I don't know what numpy is but in Snow Leopard "Python" points to Python 2.6 in /usr/bin. I duplicated the file and then replaced it with a link to 3.7. Otherwise newer python programs wouldn't run. Perhaps that is the problem.

(Jun-22-2019, 09:25 PM)amethyst Wrote: No, I tried registering with an iPad too.

I think the registration program uses Flash. iPads won't run Flash. I may have registered on another Mac running High Sierra. I don't recall.
Quote
#6
I had exactly the same problem, installer error after downloading versions of Python greater than 3.7.0. I tried each of the four updates (3.7.1, 3.7.2, 3.7.3 and 3.7.4) and they all failed. 3.7.0 installs successfully - MacOS X 10.6.

For those struggling with older browsers, TenFourFox has a good go at resembling a modern browser. Strictly speaking it's PPC, but if you download the "G3" version it'll run on Intel-based Macs.

Any way to resolve the problem with the 10.6/32-bit installer?

Curiously enough, the 64-bit installer runs and says it has done the job, but obviously does not install anything that works!
Quote
#7
A option is pyenv Simple Python Version Management work on Mac build environment

Installing Python 3 on Mac OS X this for me would be a second option,and not as ideal and safe as pyenv.
Quote

Top Page

Forum Jump:


Users browsing this thread: 1 Guest(s)