Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Compiling a Python Package on Windows
#1
My apology if this may not be the right place to post my question. I recently had to update Windows 10 system on a Lenovo Yoga 910 laptop. Following the system update, I successfully installed Python 3.7.2, which I primarily use with Abjad, a music composition package.

The installation of the Abjad package was successful and all required components for the package appear to be successfully installed and callable from the terminal. However, when I compile it I get this error message:
Output:
Python 3.7.2 (tags/v3.7.2:9a3ffc0492, Dec 23 2018, 23:09:28) [MSC v.1916 64 bit (AMD64)] on win32 Type "help", "copyright", "credits" or "license" for more information. >>> import abjad >>> note = abjad.Note() >>> abjad.show(note) Traceback (most recent call last): File "<stdin>", line 1, in <module> File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\top\show.py", line 51, in show result = abjad.persist(argument).as_pdf(**keywords) File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\system\PersistenceManager.py", line 234, in as_pdf **keywords File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\system\PersistenceManager.py", line 67, in as_ly lilypond_file = illustrate_function(**keywords) File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\core\Component.py", line 118, in __illustrate__ lilypond_file = abjad.LilyPondFile.new(self) File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\lilypondfile\LilyPondFile.py", line 990, in new use_relative_includes=use_relative_includes, File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\lilypondfile\LilyPondFile.py", line 147, in __init__ token = LilyPondVersionToken() File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\lilypondfile\LilyPondVersionToken.py", line 27, in __init__ version_string = abjad_configuration.get_lilypond_version_string() File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\site-packages\abjad\system\AbjadConfiguration.py", line 412, in get_lilypond_version_string proc = subprocess.Popen(command, shell=True, stdout=subprocess.PIPE) File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\subprocess.py", line 775, in __init__ restore_signals, start_new_session) File "C:\Users\nagym\AppData\Local\Programs\Python\Python37\lib\subprocess.py", line 1178, in _execute_child startupinfo) FileNotFoundError: [WinError 2] The system cannot find the file specified >>>
I don't think that the problem I have may necessarily be related to the above Python package installation, given that the same package compiles just fine on Linux and Mac systems. In fact, the package worked perfectly on Windows before the update.

While I have already inquired about this on relevant Abjad forum sites, I wonder if perhaps some folks on this list with more extensive Windows-Python background may be able to read the above error message and point me in the right direction? Could it be that what I'm experiencing may be more like an IT issue, or perhaps a lack of proper Windows setup to compile a Python package?

Once again, my apology for the lack of knowledge to determine what's not working properly. Any help is greatly appreciated!

Thank you!
Quote
#2
i would consider making an issue on their github
Quote
#3
Many thanks for your advice. I did post a comment on their GitHub.

Resetting the PC solved the problem. I'm still not sure what was the cause of this issue and why Python didn't want to compile the package earlier.

I appreciate the opportunity to ask the question.
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  python 3 and python 2 pips not working in windows gtx 3 152 Aug-17-2019, 06:24 PM
Last Post: snippsat
  Installed Python3.7 from package, trying to run pip3.7 does not work JBristow1729 4 246 Aug-11-2019, 08:24 AM
Last Post: michaellossagk
  Best method: Python script called from another app, package as complete executable ironfelix717 2 110 Jul-24-2019, 07:39 AM
Last Post: DeaD_EyE
  Can't decide - install modules with Ubuntu package manager (apt) or pip3 in venv Thisisaline 6 230 Jul-19-2019, 04:58 PM
Last Post: snippsat
Question python parser windows firewall log Jonub 0 108 Jul-16-2019, 06:36 PM
Last Post: Jonub
  I need help! How to package python code with other component into an exe file?? Wendy 4 192 Jul-15-2019, 01:29 PM
Last Post: snippsat
  IndentationError on installed package evvvonder 3 413 Jun-29-2019, 10:30 PM
Last Post: Gribouillis
  Problem with importing an installed package Reverend_Jim 4 474 Jun-14-2019, 10:20 PM
Last Post: Reverend_Jim
  Logger file rotation not working when python code started from windows service as exe nirvantosh 1 227 Jun-14-2019, 03:58 PM
Last Post: nirvantosh
  Error in compiling cython extension on Python 3.6.4 on Windows 8 goldenmean 3 280 Jun-05-2019, 09:37 PM
Last Post: Larz60+

Forum Jump:


Users browsing this thread: 1 Guest(s)