Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 I have BeautifulSoup instaled
#21
what do I do just put the file in to the scrip folder?
Quote
#22
What script? pip should already be there! this is where pip is located.
Pip goes out to the web and fetches what it needs to install.
Please ... just follow the instructions ... verbatim!
Quote
#23
I updated pip and I am in python2.7/scripts
it will not install it, see error:
c:\Python2.7\Scripts>python -m pip install -U pip
Collecting pip
Downloading pip-9.0.0-py2.py3-none-any.whl (1.3MB)
100% |################################| 1.3MB 86kB/s
Installing collected packages: pip
Found existing installation: pip 8.1.2
Uninstalling pip-8.1.2:
Successfully uninstalled pip-8.1.2
Successfully installed pip-9.0.0

c:\Python2.7\Scripts>pip install beautifulsoup4
Fatal error in launcher: Unable to create process using '"'

c:\Python2.7\Scripts>pip install bs4
Fatal error in launcher: Unable to create process using '"'

c:\Python2.7\Scripts>pip install beautifulsoup4
Fatal error in launcher: Unable to create process using '"'

c:\Python2.7\Scripts>
Quote
#24
(Nov-04-2016, 05:55 PM)Blue Dog Wrote: what do I do just put the file in to the scrip folder?
The files are already there,pip comes pre-installed on 2.7.11.
Just follow what i have post update and install,and it should work.

If need wheel like lxml(because it has C dependency),
then you can place that wheel(.whl) in Scripts folder.
And eg do:
c:\Python2.7\Scripts>pip install lxml-3.6.4-cp27-cp27m-win_amd64.whl
Quote
#25
(Nov-04-2016, 06:11 PM)Blue Dog Wrote: c:\Python2.7\Scripts>pip install beautifulsoup4
Fatal error in launcher: Unable to create process using '"'
Hmm look strange,maybe problem with pip 9.0,which just came out.
i shall to i test and see.
Quote
#26
it did the same with the old pip.
Quote
#27
Quote:c:\Python2.7\Scripts>python -m pip install -U pip
Do not use python here just:
c:\Python2.7\Scripts>pip install --upgrade pip
The try install again.
Quote
#28
I get the same when I try to install lxml

Microsoft Windows [Version 6.1.7601]
Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Users\renny and kite>cd c:\Python2.7\Scripts

c:\Python2.7\Scripts>pip install lxml-3.6.4-cp27-cp27m-win_amd64.whl
Fatal error in launcher: Unable to create process using '"'

c:\Python2.7\Scripts>

same thing
c:\Python2.7\Scripts>pip install --upgrade pip
Fatal error in launcher: Unable to create process using '"'

c:\Python2.7\Scripts>
Quote
#29
What step says to update pip?

To be sure you are using the correct version of pip:
pip -V .. You should see python 2.7

1. From a command prompt
2. cd c:\Python27\scripts Change this if python 2.7 is located in a different directory
3. pip install beautifulsoup4

dueling replies
Quote
#30
I can see that python is not really ready to be used as a tool yet. Just for people that have time to play around with something that does not work. I uninstalled both 2.7 and 3.5, going back to C# that does work.
Quote

Top Page

Forum Jump:


Users browsing this thread: 1 Guest(s)