Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 ImportError: No module named xlrd
#1
I am trying to extract data from XL sheet and I tried to use the below

import xlrd
Error:
ImportError: No module named xlrd
( I also tried "pandas", "openpyxl"; Same error resulted)

When I checked in lib folder, I was able to find xlrd package

in the path - /projects/software/miniconda_3.7.3/pkgs/xlrd-1.1.0-py35_0/lib/python3.5/site-packages/xlrd

can anyone please help me how to resolve this?
Yoriz wrote Sep-20-2019, 03:35 PM:
Please post all code, output and errors (in it's entirety) between their respective tags. I did it for you this time, Here are instructions on how to do it yourself next time.
Quote
#2
Do you have more than one install of python / are you sure you are using miniconda_3.7.3 in this instance.
Quote
#3
Yes, I believe we do have the below.

python -V
Python 2.7.13

Looks like, we are not referring to below miniconda_3.7.3..

Please let me know how to utilize or install or invoke packages(specifically xlrd)
Quote
#4
It depends how you are running the code ?
Quote
#5
Thank you!
Quote
#6
hi,
type
python3 -v
and check it's version
also, use
pip3 install xlrd
to install it
the same is true with pandas
dhiliptcs likes this post
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  ModuleNotFoundError: No module named ‘CommandNotFound’ jiapei100 5 268 Feb-22-2020, 08:34 PM
Last Post: snippsat
  ModuleNotFoundError: No module named 'xxxx' darpInd 2 293 Feb-06-2020, 11:33 AM
Last Post: darpInd
  Issues installing xlrd KipCarter 2 222 Jan-24-2020, 12:20 PM
Last Post: KipCarter
  'No module named tkinter.messagebox' - PyInstaller ironfelix717 7 261 Jan-19-2020, 06:56 AM
Last Post: buran
  Python ModuleNotFoundError: No module named 'sender_model' when running an Alembic mi fcardinaliuk 1 410 Nov-13-2019, 07:57 PM
Last Post: micseydel
  ModuleNotFoundError: No module named 'pygame' Cath 3 2,392 Oct-18-2019, 05:59 PM
Last Post: metulburr
  ModuleNotFoundError: No module named '...' tlg265 1 1,524 Oct-09-2019, 06:47 PM
Last Post: maxtimbo
  ImportError: No module named tkinter. kouadio 1 784 Oct-08-2019, 10:59 PM
Last Post: Larz60+
  XLRD Package not be able to call dhiliptcs 2 270 Sep-24-2019, 05:21 PM
Last Post: dhiliptcs
  ModuleNotFoundError: No module named 'psutil' after creating .exe ? ABhishek 3 2,135 Jul-30-2019, 01:44 PM
Last Post: ABhishek

Forum Jump:


Users browsing this thread: 1 Guest(s)