Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Live Server on VSCode
#1
I am developing a Flask site and using Live Server plugin.
Examples that I have seen show the browser opening within VSCode, when 'Open with Live Server' is selected on an HTML file.
When I use it, all works well except that the localhost comes up in a separated, rather that attached browser (I use Firefox).
I am working on Linux Mint.
I have been unsuccessful in figuring out how to change this.
If you have experience with this, please share.

Thanks in advance.
Quote
#2
bump
Quote
#3
Larz which extension do you refer to?
Live Server by Ritwick Dey
Live Server Preview by negokaz
HQ Live Server by hqjs
MIX Live Server by varomix
or something else?
at least for the first one I think it clearly opens in a browser (as separate window) in all examples I have seen
Quote
#4
Buran,

Thanks for responding.
I never knew there were more that one!

The one I have installed is Ritwick Dey.
That's might have been my problem, but it appears that I lucked out.
This is the one where the browser should appear within VSCode.

I am taking a video course that I purchased from Packt (Bootstrap4FromScratchVideo), which asked to install Live server, and assuming (which I never should do), there was only one, installed Dey's.

Now that I am looking at the proper documentation, I see here: https://github.com/ritwickdey/vscode-liv...ettings.md a section on the browser.

Thanks for the lift, I was stumbling.
Quote
#5
I also thought it's that one (most installs, etc.)
It looks the only option that MAY be related is liveServer.settings.NoBrowser
Not sure if it do what you want - as I said for that extension I didn't see example open in the VSCode. However some of the others do have such example I think. Would be interesting to see what you found at the end.
Quote
#6
The video course that I am taking has an example of the browser within VSCode, but I am thinking that it was created on a windows machine.
I'll try playing with the NoBrowser setting and report my results.
Even If I can't get it to work this way, it's not the end of the world.
I just live having all of my tools in one box.
Quote
#7
i tried setting:
"liveServer.settings.NoBrowser": False,
and didn't notice anything New.
I noticed that the default is False, so no difference here.
I looked closer at the screen shown in my tutorial, and I now think that they were two separate windows side by side, and not an internal VSCode browser.
I wanted it to be part of VSCode, but no, and I can (have no choice, really) live with separate windows.
This is still a pretty cool plugin, as changes show on in the browser immediately as they are changed in code.
That's a big time saver when trying different class values for example.
Quote

Top Page

Forum Jump:


Users browsing this thread: 1 Guest(s)