Bottom Page

Thread Rating:
  • 2 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 New to python : need to install hwcounter
#11
each version of python has it's own copy of pip which is designed specifically for that version of python.
this is why the questions about pip -V, etc. which will show the python version it is tied to.
When you install python, you have the option to set up environment variables or not, if you chose not to do so, then pip will be tied to the old version, not the new one.

One way to totally avoid this is to always use virtual environments and pipenv then the problem goes away because each project can have it's own environment, and separate python and pip.

There is a tutorial on how to do this here: https://python-forum.io/Thread-Part-1-Li...3#pid18603
I don't understand why you are having such a problem.

So, a few more questions:
which operating system are you using?
where was python installed?
Quote
#12
Hi Larz60,

Thanks.

I had tried using virtual environment using virtualenv and virtualenv-win.

(commscheck) C:\Users\Sue\dev\Commscheck>pip -V
pip 18.1 from c:\users\sue\envs\commscheck\lib\site-packages\pip (python 3.5)

(commscheck) C:\Users\Sue\dev\Commscheck>python -V
Python 3.5.4

(commscheck) C:\Users\Sue\dev\Commscheck>pip install -U setuptools
Requirement already up-to-date: setuptools in c:\users\sue\envs\commscheck\lib\site-packages (40.6.3)

(commscheck) C:\Users\Sue\dev\Commscheck>pip install -U wheel
Requirement already up-to-date: wheel in c:\users\sue\envs\commscheck\lib\site-packages (0.32.3)
I believe these are the right versions ?

Still get the same error when

pip install hwCounter
Sorry - I didn't answer the question about operating system. I'm on Windows 10.

I'm wondering if my problem is something to do with the C++ compiler. There were a number of options for selecting which C++ tools to download and install and I'm wondering if I have the right one. If my laptop is 64bit would having downloaded x86 version be a problem ? I'm pretty sure I downloaded the 14.0 version which I think is needed......

Sue.
Quote
#13
I don't think, but you can never be sure about MS OS, that windows 10 would have anything to do with it.
So, you can do a test. Fine the directory where python 3.5.4 in installed, if necessary you can use power shell command
Quote:get-childitem C:\yourdir -include *.c -recursive |Select-String -pattern sqlcommand

Sorry can't give exact command as I don't have windows running anywhere. I know the -include *.c won't be part of it.
but once you have found where python is insatlled, change to the scripts directory just below python home directory
you will find pip there, try running pip from there, and don't run setuptools or anything else, just pip
Quote

Top Page

Forum Jump:


Users browsing this thread: 1 Guest(s)