Bottom Page

Thread Rating:
  • 3 Vote(s) - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 [Part-1]Python 3.6/3.7 and pip installation under Windows
#1
Python 3.7 install last in this thread.

This is a advice how to install Python and pip under Windows | Part-2
It's advisable to change the long default Path,to a simper Path eg C:\Python36.

Python download.
Choose a executable installer  32-bit or 64-bit.

İmage



Under Customize installation make sure that pip is marked on.

İmage



Here also choose Path C:\Python36

İmage



Finish install.

İmage


Restart

Testing that python and pip command work from cmd.
Start cmd:

Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. Med enerett.
   
C:\Windows\System32>cd\
   
C:\>python
Python 3.6.0 (v3.6.0:41df79263a11, Dec 23 2016, 07:18:10) [MSC v.1900 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> exit()
   
C:\>pip -V
pip 9.0.1 from c:\python36\lib\site-packages (python 3.6)
C:\>
Now that all work,can eg test pip with install of Requests.
C:\>pip install requests
Collecting requests
  Using cached requests-2.13.0-py2.py3-none-any.whl
Installing collected packages: requests
Successfully installed requests-2.13.0

C:\>python
Python 3.6.1 (v3.6.1:69c0db5, Mar 21 2017, 17:54:52) [MSC v.1900 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import requests
>>> r = requests.get('https://www.python.org/')
>>> r.status_code
200
>>> r.encoding
'utf-8'
>>> r.headers['date']
'Tue, 09 May 2017 15:34:57 GMT'
metulburr, wavic, Larz60+ like this post
Quote
#2
Would like to add some things.


A lot of people come unfamiliar with using the command prompt and are confused in thinking pip is ran on the python interpreter (ie. >>> prompt), but is ran on the system's command prompt (ie. windows C:\ prompt, linux username@computername ~$).


Also your pip may be out of date.

Quote:pip : You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
This is just a warning. Your package will still install, but it is just warning you that your pip is not current. You can update pip by the command they give you pip install --upgrade pip


You can use pip to upgrade your existing packages
pip install -U youtube-dl
snippsat and wavic like this post
Quote
#3
Python 3.7
Installasjon work the same 3.6.
But the Add Python 3.7 to Path did not overwrite the 3.6 Path,so i had to change Path manually to point to 3.7.
The setup look:
İmage

pip is automatically marked on,do not utmark it.

Fixing Path if needed
For new user the Path to 3.7 should be okay.
Here how to change Environment Variables Path
İmage


Check python and pip
Check that python and pip point to 3.7 from anywhere cmd/cmder.
C:\
λ python -V
Python 3.7.0

C:\
λ pip -V
pip 10.0.1 from c:\python37\lib\site-packages\pip (python 3.7)
python my_scrip.py will use Python 3.7.
pip install something will install to Python 3.7

Access other versions
All other version installed can be accessed by using py(this is a py.exe that get installed in Path of Windows)
C:\                                                                                                            
λ py -3.6 -V                                                                                                   
Python 3.6.4                                                        
                                                     
C:\                                                                                                            
λ py -2.7 -V                                                                                                   
Python 2.7.9                                                                                                   
                                                                                                               
C:\                                                                                                            
λ # Using pip to install to 2.7                                                                            
λ py -2.7 -m pip install logzero                                                                               
Requirement already satisfied: logzero in c:\python27\lib\site-packages 
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Part-1]Linux Python 3 environment snippsat 1 10,435 May-25-2017, 05:14 PM
Last Post: snippsat
  [Part-2]Python environment Windows snippsat 4 13,082 May-24-2017, 10:44 AM
Last Post: metulburr

Forum Jump:


Users browsing this thread: 1 Guest(s)