Hello guest, if you read this it means you are not registered. Click here to register in a few simple steps, you will enjoy all features of our Forum.
Bottom Page

Thread Rating:
  • 2 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[PyGame] Image not found error
#1
Hey guys,
I'm beginner in Python 3.5 and Pygame. With help of YouTube tutorials I'm trying to code my first very basic "game". I am using Mac OS and every time I try to add image (.png) to my game it writes error: Failed loading libpng.dylib: dlopen(libpng.dylib, 2): image not found
Can you help me please?
Quote
#2
try this
brew install sdl sdl_image sdl_mixer sdl_ttf portmidi

*Describe the environment in which it occurs.                                    *Describe the symptoms of your problem clearly.
*Describe the research you did to try and understand the problem.      *Describe the goal, not the step. 
*Use meaningful, specific subject headers                                          *Write in clear, grammatical, correctly-spelled language
*Describe the problem's symptoms, not your guesses                         *Describe your problem's symptoms in chronological order
*Describe the diagnostic steps you took to try and pin down the problem yourself.
*Describe any possibly relevant recent changes in your computer or software configuration. 
*Provide a way to reproduce the problem in a controlled environment.
Quote
#3
Sorry, maybe its bad question but.. where should I write that line?
Quote
#4
its a system command to install dependencies 

open a terminal and input that
*Describe the environment in which it occurs.                                    *Describe the symptoms of your problem clearly.
*Describe the research you did to try and understand the problem.      *Describe the goal, not the step. 
*Use meaningful, specific subject headers                                          *Write in clear, grammatical, correctly-spelled language
*Describe the problem's symptoms, not your guesses                         *Describe your problem's symptoms in chronological order
*Describe the diagnostic steps you took to try and pin down the problem yourself.
*Describe any possibly relevant recent changes in your computer or software configuration. 
*Provide a way to reproduce the problem in a controlled environment.
Quote
#5
-bash: brew: command not found
Quote
#6
i dont even own a mac, so im not sure. I just googled your answer. And i googled your error as well to find this
http://stackoverflow.com/questions/20381...ew-on-os-x
*Describe the environment in which it occurs.                                    *Describe the symptoms of your problem clearly.
*Describe the research you did to try and understand the problem.      *Describe the goal, not the step. 
*Use meaningful, specific subject headers                                          *Write in clear, grammatical, correctly-spelled language
*Describe the problem's symptoms, not your guesses                         *Describe your problem's symptoms in chronological order
*Describe the diagnostic steps you took to try and pin down the problem yourself.
*Describe any possibly relevant recent changes in your computer or software configuration. 
*Provide a way to reproduce the problem in a controlled environment.
Quote
#7
Thank you so much! It worked!
metulburr likes this post
Quote
#8
so is your original problem fixed or just installing brew?
*Describe the environment in which it occurs.                                    *Describe the symptoms of your problem clearly.
*Describe the research you did to try and understand the problem.      *Describe the goal, not the step. 
*Use meaningful, specific subject headers                                          *Write in clear, grammatical, correctly-spelled language
*Describe the problem's symptoms, not your guesses                         *Describe your problem's symptoms in chronological order
*Describe the diagnostic steps you took to try and pin down the problem yourself.
*Describe any possibly relevant recent changes in your computer or software configuration. 
*Provide a way to reproduce the problem in a controlled environment.
Quote
#9
I installed brew and my problem is partly fixed. When I save image as .png or .jpeg it writes error but once I saved it as .gif it worked. Its fixed for me because I don't really care if its .png or .gif I am just glad it works.
nilamo likes this post
Quote

Top Page

Forum Jump:


Users browsing this thread: 1 Guest(s)