Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 [WxPython] wxpython and python 3.6 on linux
I am trying to install wxpython phoenix for python 3.6 on my Linux Mint 18.2 and am getting a lot of errors.
I have pip 3.6 installed and it runs okay but the install of wxpython fails.
sudo -H pip3.6 install wxpython
[sudo] password for norman: 
Collecting wxpython
  Downloading wxPython-4.0.1.tar.gz (67.9MB)
    100% |████████████████████████████████| 67.9MB 26kB/s 
It runs so far and then I get
Checking for header Python.h : :-( Asking python-config for pyembed --cflags flags : yes Asking python-config for pyembed --libs flags : yes Asking python-config for pyembed --ldflags flags : yes Getting pyembed flags from python-config : yes Asking python-config for pyext --cflags flags : yes Asking python-config for pyext --libs flags : yes Asking python-config for pyext --ldflags flags : yes Getting pyext flags from python-config : Could not build python extensions The configuration failed (complete log in /tmp/pip-build-e9v1g771/wxpython/build/waf/3.6/gtk3/config.log) Command '"/usr/local/bin/python3.6" /tmp/pip-build-e9v1g771/wxpython/bin/waf-1.7.15-p1 --wx_config=/tmp/pip-build-e9v1g771/wxpython/build/wxbld/gtk3/wx-config --gtk3 --python="/usr/local/bin/python3.6" --out=build/waf/3.6/gtk3 configure build ' failed with exit code 1. Finished command: build_py (0.864s) Finished command: build (0m1.395s) Command '"/usr/local/bin/python3.6" -u build' failed with exit code 1.
Cannot post log because the process cleaned up afterwards and so log not there.
Any help would be appreciated.
I tried to install wxpython by doing

sudo -H pip3.6 install
Which it said it had done successfully
But when I tried it I got this

Python 3.6.4 (default, Mar 13 2018, 17:34:02) 
[GCC 5.4.0 20160609] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.6/site-packages/wx/", line 17, in <module>
    from wx.core import *
  File "/usr/local/lib/python3.6/site-packages/wx/", line 12, in <module>
    from ._core import *
ImportError: cannot open shared object file: No such file or directory
I tried this with several builds including 4.0.0a2 but all gave the same type of errors.
The same happened with gtk3 builds
I guess I am doing something wrong but what?
Sorted it out
 sudo add-apt-repository ppa:deadsnakes/ppa
 sudo apt-get update  
Then was able to install libpython3.6-dev, which was needed, via package manager.
metulburr likes this post
dead snakes ... sounds rather ominous

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  [PyQt] Linux - Application translation not load when run from .desktop launcher dancaer69 2 191 May-19-2019, 06:01 PM
Last Post: dancaer69
  [WxPython] Adding a Window to a Button wxPython ShashankDS 4 331 Apr-23-2019, 06:53 PM
Last Post: Yoriz
  Python3/PyQt5/gnuplot on linux erg 1 270 Mar-20-2019, 01:57 PM
Last Post: Axel_Erfurt
  WxPython in web with a cgi server jttolleson 11 734 Mar-08-2019, 05:54 PM
Last Post: Weave
  Problems using Wxpython Carles 1 536 Nov-28-2018, 03:09 PM
Last Post: Larz60+
  [WxPython] Using thread in the wxPython hildogjr 8 1,613 Aug-11-2018, 02:59 AM
Last Post: hildogjr
  Using 2 screens in wxpython Barrowman 1 767 Jun-27-2018, 07:43 PM
Last Post: Barrowman
  Trying to use code from WxPython GUI Toolkit Barrowman 3 963 Jun-26-2018, 05:43 PM
Last Post: nilamo
  [PyQt] source code is not running in REDHAT 7 linux platform shridhara 0 500 May-23-2018, 07:58 AM
Last Post: shridhara
  A little idea to remember wxPython classes Sebastian_Adil 0 784 Mar-26-2018, 10:23 PM
Last Post: Sebastian_Adil

Forum Jump:

Users browsing this thread: 1 Guest(s)