Bottom Page

Thread Rating:
  • 4 Vote(s) - 3.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 numpynot associted with correct python version
#1
When I tried to run a program using python3, I got an error that there is no package associated
with python named numpy.I remember putting one on.But according to the error it is associated with
a python 2.7.15 version. The default python then (during that numpy install) was python 2.7.15.

Yes, python 2.7.15 is on my laptop hard rive, but I compile (interpreted) with python 3.6.2.Python 2.7.15 is my default
python. If I type python -V it will be python 2.7.15.

There is no numpy associated with python 3.6.2, .So how do I change this setup so numpy is
associated with python 3.6.2, which is my preferred version for this code?

Any help appreciated.Thanks in advance.

Respectfully,

ErnestTBass
Quote
#2
Oops, I forgot to include the printout that shows the errors that I discussed
in my previous post.

I will take care of that now.

Respectfully,

ErnestTBass

PS.I am sorry I am new to this forum and i cannot figure out how to attached a file to a post.
Quote
#3
I imagine you used pip to install it for Python 2. You ought to be able to use pip3 for Python 3.
Quote
#4
Yes, that was my error. I have Python 3.5.2 and Python 3.6.2. Will pip3 work on both versions?

Any help appreciated. Thanks in advance.

Respectfully,

ErnestTBass
Quote
#5
ollecting numpy
Could not fetch URL https://pypi.python.org/simple/numpy/: There was a problem confirming the ssl certificate: Can't connect to HTTPS URL because the SSL module is not available. - skipping

Above is what I got when I typed

pip3 install numpy

please tell what i did wrong. I tried to upload the file and gave mean error. It did not like the file type. Thus I just copied
and pasted.

Any help appreciated. Thanks in advance.

Respectfully,

ErnestTBass
Quote
#6
Please I need an answer to this. It is stopping me from doing my python programming. I need the python 3 version of numpy.

As of now, I cannot install that numpy version.

I am using Ubuntu 16.05 64 bit.

Any help appreciated. Thanks in advance.


Respectfully,

ErnestTBass
Quote
#7
I'm not sure the solution to your problem, but I did some Googling and it sounds like you can either downgrade your pip version or potentially add these flags to your pip command:
Output:
--allow-all-external --allow-unverified
(I found the flags in this SO post.)
Quote
#8
Thank you I will give it a shot. It just seems to bean error that I have never seen before.

Respectfully,

ErnestTBass

That link that you gave me was format a MAC operating system. I will try anyway. I am stuck.

Thanks for your help.

Respectfully,

ErnestTBass
Quote
#9
I tried the option that requires two arguments.


Here is the output.

james@james-VirtualBox:~$ sudo pip3 install numpy --allow-all-external --allow-unverified
[sudo] password for james:
Sorry, try again.
[sudo] password for james:

Usage:
pip install [options] <requirement specifier> [package-index-options] ...
pip install [options] -r <requirements file> [package-index-options] ...
pip install [options] [-e] <vcs project url> ...
pip install [options] [-e] <local project path> ...
pip install [options] <archive url/path> ...

--allow-unverified option requires 1 argument
james@james-VirtualBox:~$

I am not sure of the syntax, but the command above seemed to be the most successful,
even with the error.

Any help on this appreciated. My version of pip3 is 9.0.1.

Thanks in advance.

Respectfully,


ErnestTBass
Quote
#10
I think that I have an approach. I have three versions of python on my hard disk on my computer. Thy are 2.7.15, 3.5.2,and 3.6.3.

I am using 3.6.3.That was installed by me last week-end. Whenever,I try to install numpy or scipy, I get the error messages that
were shown in previous posts in this thread.

Maybe it is because of python 3.6.3. It is too new. I installed python 3.6.3 by downloading the tar file and the untaring it,then /confgiure, make, make install completed the install.

Then I must have made it the default python interpreter, and it is too new for any numpy or scipy.

So, I must remove it and make python 3.5.2 the default.That seems to be the standard python 3 and maybe I will not have as much trouble as I did before.

Does this sound plausible?

Maybe, I should just make python 3.5.2 my default python interpreter

Any other suggestion.This issue has got me stuck..

Respectfully,

ErnestTBass
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  Not quite getting the correct Output from a function twinpiques 3 147 Aug-04-2019, 11:53 PM
Last Post: twinpiques
  read text file and write into html with correct link jacklee26 4 146 Aug-02-2019, 05:48 AM
Last Post: jacklee26
  Trouble importing modules on a new python version snackman_barry 2 140 Jul-12-2019, 11:15 AM
Last Post: snackman_barry
  Version of glob for that Supports Windows Wildcards? Reverend_Jim 5 442 Jun-18-2019, 06:31 PM
Last Post: Reverend_Jim
  Help with finding correct topic in Python learning yahya01 1 276 Jun-06-2019, 05:01 PM
Last Post: buran
  Return in correct json format UtiliseIT 3 339 May-13-2019, 11:24 AM
Last Post: snippsat
  [split] Using this Python version of text2pdf jonsnow1221 1 176 May-07-2019, 07:48 PM
Last Post: micseydel
  How to continue in loop until correct input received sunnyarora 10 470 May-04-2019, 02:37 PM
Last Post: Yoriz
  Using this Python version of text2pdf Pedroski55 1 240 Apr-15-2019, 08:12 AM
Last Post: Pedroski55
  can't install package web in version python 3.7 a21250450 1 241 Mar-29-2019, 11:28 AM
Last Post: Larz60+

Forum Jump:


Users browsing this thread: 1 Guest(s)