Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 pip install pandas ERROR
#1
Trying to install pandas today but i get this error report:

Collecting pandas
Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ProtocolError('Connection aborted.', ConnectionResetError(10054, 'An existing connection was forcibly closed by the remote host', None, 10054, None))': /simple/pandas/
Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ProtocolError('Connection aborted.', ConnectionResetError(10054, 'An existing connection was forcibly closed by the remote host', None, 10054, None))': /simple/pandas/
Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ProtocolError('Connection aborted.', ConnectionResetError(10054, 'An existing connection was forcibly closed by the remote host', None, 10054, None))': /simple/pandas/
Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ProtocolError('Connection aborted.', ConnectionResetError(10054, 'An existing connection was forcibly closed by the remote host', None, 10054, None))': /simple/pandas/
Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ProtocolError('Connection aborted.', ConnectionResetError(10054, 'An existing connection was forcibly closed by the remote host', None, 10054, None))': /simple/pandas/
Could not find a version that satisfies the requirement pandas (from versions: )
No matching distribution found for pandas

In the command prompt I am typing pip install pandas.
How do i fix it?
Thanks in Advance!
Quote
#2
Hey,
I am not sure why that is happening, although there are alternative ways of downloading modules. You could try using easy_install which is run in cmd just like pip. You could also try manually downloading it from PyPi.
Hope I helped :)
Quote
#3
This could be network(firewall ect..) problem or access problem to PyPi problem.
python -m pip install --trusted-host pypi.python.org --trusted-host files.pythonhosted.org --trusted-host pypi.org --upgrade pip
Try install after upgrade pip.
Install directly would be.
pip install --trusted-host=pypi.org --trusted-host=files.pythonhosted.org pandas
Proxy example for bypass firewall.
python.exe -m pip install pandas --proxy="proxy.com:8080"
Quote
#4
It´s solved now!
Thank you both
Quote
#5
(May-17-2019, 11:40 PM)pythondudu Wrote: It´s solved now!
Thank you both
How to fix it?
Quote
#6
(May-17-2019, 08:43 AM)snippsat Wrote: This could be network(firewall ect..) problem or access problem to PyPi problem.
python -m pip install --trusted-host pypi.python.org --trusted-host files.pythonhosted.org --trusted-host pypi.org --upgrade pip
Try install after upgrade pip.
Install directly would be.
pip install --trusted-host=pypi.org --trusted-host=files.pythonhosted.org pandas
Proxy example for bypass firewall.
python.exe -m pip install pandas --proxy="proxy.com:8080"
After I install pandas
C:\Users\sara\AppData\Local\Programs\Python\Python38>python.exe -m pip install pandas --proxy="proxy.com:8080"
Requirement already satisfied: pandas in c:\users\sara\appdata\local\programs\python\python38\lib\site-packages (1.0.3)
Requirement already satisfied: pytz>=2017.2 in c:\users\sara\appdata\local\programs\python\python38\lib\site-packages (from pandas) (2019.3)
Requirement already satisfied: numpy>=1.13.3 in c:\users\sara\appdata\local\programs\python\python38\lib\site-packages (from pandas) (1.18.1)
Requirement already satisfied: python-dateutil>=2.6.1 in c:\users\sara\appdata\local\programs\python\python38\lib\site-packages (from pandas) (2.8.1)
Requirement already satisfied: six>=1.5 in c:\users\sara\appdata\local\programs\python\python38\lib\site-packages (from python-dateutil>=2.6.1->pandas) (1.14.0)

but I still have the same error when run .py program
Quote
#7
(Mar-26-2020, 09:22 AM)liliyana Wrote: but I still have the same error when run .py program
What error?
Installation look okay,test that if work from command line before using any editors.
Look at Python 3.8 (3.6-3.7) and pip installation under Windows
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  error bars with dataframe and pandas Hucky 4 295 Apr-27-2020, 02:02 AM
Last Post: Hucky
  How to install tensorflow? It shows as error jaroslavtavgen 1 180 Apr-26-2020, 10:09 PM
Last Post: Larz60+
  pandas error Scott 2 1,087 Feb-05-2020, 07:22 PM
Last Post: Scott
  pandas DataReader error on all data sources glidecode 5 9,973 Sep-25-2019, 02:10 PM
Last Post: perfringo
  Key error when using adodbapi, azure and pandas mazamus 2 944 Sep-11-2019, 06:54 AM
Last Post: TomKom
  pandas install error loren41 5 1,167 May-20-2019, 06:42 PM
Last Post: loren41
  utf-8 error with pandas read_csv logues 0 1,550 Oct-23-2018, 05:25 PM
Last Post: logues
  Using pandas, index error fyec 1 1,878 Aug-01-2018, 09:25 AM
Last Post: volcano63
  Error: Slicing a single date from Pandas cheerful 0 827 Jul-22-2018, 08:09 PM
Last Post: cheerful
  PIP install error alex36540 15 21,863 Dec-16-2017, 01:09 PM
Last Post: alex36540

Forum Jump:


Users browsing this thread: 1 Guest(s)