Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 python ibeacon rasp pi localization
Hello, I'm trying to find the distance of ibeacon with raspberry pi and when I run the python code I get the following error;

File "", line 29
if 0<= calculate_accuracy(txpower, rssi)calculate_accuracy< 2:
SyntaxError: invalid syntax
You have extra calculate_accuracy on that line
(Feb-12-2019, 03:00 PM)buran Wrote: You have extra calculate_accuracy on that line
I've solved this problem, but now I'm suffering from a bluepy installation.
pi@raspberrypi:~ $ sudo pip install bluepy Collecting bluepy Exception: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/pip/", line 215, in main status =, args) File "/usr/lib/python2.7/dist-packages/pip/commands/", line 353, in run File "/usr/lib/python2.7/dist-packages/pip/", line 749, in build self.requirement_set.prepare_files(self.finder) File "/usr/lib/python2.7/dist-packages/pip/req/", line 380, in prepare_files ignore_dependencies=self.ignore_dependencies)) File "/usr/lib/python2.7/dist-packages/pip/req/", line 554, in _prepare_file require_hashes File "/usr/lib/python2.7/dist-packages/pip/req/", line 278, in populate_link = finder.find_requirement(self, upgrade) File "/usr/lib/python2.7/dist-packages/pip/", line 465, in find_requirement all_candidates = self.find_all_candidates( File "/usr/lib/python2.7/dist-packages/pip/", line 423, in find_all_candidates for page in self._get_pages(url_locations, project_name): File "/usr/lib/python2.7/dist-packages/pip/", line 568, in _get_pages page = self._get_page(location) File "/usr/lib/python2.7/dist-packages/pip/", line 683, in _get_page return HTMLPage.get_page(link, session=self.session) File "/usr/lib/python2.7/dist-packages/pip/", line 792, in get_page "Cache-Control": "max-age=600", File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 501, in get return self.request('GET', url, **kwargs) File "/usr/lib/python2.7/dist-packages/pip/", line 386, in request return super(PipSession, self).request(method, url, *args, **kwargs) File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 488, in request resp = self.send(prep, **send_kwargs) File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 609, in send r = adapter.send(request, **kwargs) File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/", line 47, in send resp = super(CacheControlAdapter, self).send(request, **kw) File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 423, in send timeout=timeout File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 643, in urlopen _stacktrace=sys.exc_info()[2]) File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/", line 315, in increment total -= 1 TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
buran wrote Feb-12-2019, 04:27 PM:
Please, use error tags when post traceback
are you running behind proxy?
If you google the error you will see it could be number of reasons
I guess that's why I'm using the dorm Internet. I think there's restriction.

@buran I have now installed the internet from my phone. Now I have this problem.

Traceback (most recent call last):
File "", line 1, in <module>
import blescan
ImportError: No module named blescan
where your code comes from? what is bluescan? i.e. if you create the code you should now what package module it is. is it installed? is it the one part of bluepy?
Obviously it's this one
and it is based on
@buran I apologize, but I can't find the ibeacon this time.
so I could not access the files that solved the problem.
pi@raspberrypi:~/Desktop/bluetooth_indoor_localization $ python
ble thread started
error accessing bluetooth device...

I just can't find the device right now.
I really cannot help more
(Feb-12-2019, 04:33 PM)buran Wrote: I really cannot help more
okay but why ?
sorry, i didn't realise it's your code that print that error accessing bluetooth device... and I didn't have any idea why you cannot access the device.
remove the try/except block.
by using blank except you shadow any exception message that will tell what's wrong
you should always use specific error that you can catch

EDIT: I see - scan(sock) should be scan_sock(sock)

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  Rasp Pi: "lp: not allowed to print" when using a python script montypython76 1 1,440 Jun-13-2017, 09:10 AM
Last Post: DeaD_EyE

Forum Jump:

Users browsing this thread: 1 Guest(s)