Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
remember me how to delete python2.7 in Linux
#11
@ Dead_Eye Many thanks. Time here is 18h14. I will look to all that to-morrow, because my internet works badly at the end of the evening.
Quote
#12
I went to nano. I wrote the 3 lines. I gave the name of the file (sylas). I don't understand M-D(DOS format)
Error:
sylvain@sylvain-HP-Laptop-15-bw0xx:~$ echo $PATH /home/sylvain/.local/share/umake/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
Quote
#13
I wrote again all. Unfortunately no progress:
Error:
sylvain@sylvain-HP-Laptop-15-bw0xx:~$ echo $PYENV_ROOT sylvain@sylvain-HP-Laptop-15-bw0xx:~$

With the uploads I get:
sylvain@sylvain-HP-Laptop-15-bw0xx:~/Téléchargements$ cd pyenv-master;ls
bin           CONDUCT.md  plugins                 src
CHANGELOG.md  libexec     pyenv.d                 terminal_output.png
COMMANDS.md   LICENSE     pyenv-installer-master  test
completions   Makefile    README.md
Quote
#14
Maybe with this you can help me!
sylvain@sylvain-HP-Laptop-15-bw0xx:~/Téléchargements/pyenv-master/bin$ ./pyenv
pyenv 1.2.6
Usage: pyenv <command> [<args>]

Some useful pyenv commands are:
   commands    List all available pyenv commands
   local       Set or show the local application-specific Python version
   global      Set or show the global Python version
   shell       Set or show the shell-specific Python version
   install     Install a Python version using python-build
   uninstall   Uninstall a specific Python version
   rehash      Rehash pyenv shims (run this after installing executables)
   version     Show the current Python version and its origin
   versions    List all Python versions available to pyenv
   which       Display the full path to an executable
   whence      List all Python versions that contain the given executable

See `pyenv help <command>' for information on a specific command.
For full documentation, see: https://github.com/pyenv/pyenv#readme
Quote
#15
For the moment I use pyenv with; "/home/sylvain/Téléchargements/pyenv-master/bin/pyenv"(Téléchargemets stands for uploads). It works . So I learned that if you have not installed Python-2.7.14 with pyenv, you cannot uninstall it with pyenv.
Quote
#16
@snippsat I should like very much to have 3.6.3 instead of 2.7.14 as default. 3.6.3 is already installed but not with pyenv. So I tried to install it pyenv. Impossible
Error:
sylvain@sylvain-HP-Laptop-15-bw0xx:~$ /home/sylvain/Téléchargements/pyenv-master/bin/pyenv install 3.6.3 Downloading Python-3.6.3.tar.xz... -> https://www.python.org/ftp/python/3.6.3/Python-3.6.3.tar.xz Installing Python-3.6.3... BUILD FAILED (Ubuntu 17.10 using python-build 1.2.6-4-gb7eea900) Inspect or clean up the working tree at /tmp/python-build.20180812112817.13188 Results logged to /tmp/python-build.20180812112817.13188.log Last 10 log lines: ensurepip._main() File "/tmp/python-build.20180812112817.13188/Python-3.6.3/Lib/ensurepip/__init__.py", line 189, in _main default_pip=args.default_pip, File "/tmp/python-build.20180812112817.13188/Python-3.6.3/Lib/ensurepip/__init__.py", line 102, in bootstrap _run_pip(args + [p[0] for p in _PROJECTS], additional_paths) File "/tmp/python-build.20180812112817.13188/Python-3.6.3/Lib/ensurepip/__init__.py", line 27, in _run_pip import pip zipimport.ZipImportError: can't decompress data; zlib not available Makefile:1079 : la recette pour la cible « install » a échouée make: *** [install] Erreur 1
Quote
#17
(Aug-12-2018, 09:38 AM)sylas Wrote: @snippsat I should like very much to have 3.6.3 instead of 2.7.14 as default.
As usually you have messed it up and not followed @DeaD_EyE instruction.
I also have tutorial here(setting up pyenv) which i have linked to you before.
Quote:I went to nano. I wrote the 3 lines. I gave the name of the file (sylas). I don't understand M-D(DOS format)
Arggg you shall give the file a new name it has be ~/.bashrc(just save as same name) you just save after adding 3 lines under.
export PATH="~/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
eval "$(pyenv virtualenv-init -)"
So if i look at ~/.bashrc last 10 lines,you see that i have placed those 3 lines last.
mint@mint ~ $ tail -n 10 ~/.bashrc 
fi
 
if [ -x /usr/bin/mint-fortune ]; then
     /usr/bin/mint-fortune
fi
 
export PATH="~/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
eval "$(pyenv virtualenv-init -)"
Quote:/pyenv-master/bin/pyenv install 3.6.3
This is just wrong as you try to use it from Repo download.

This how it look when installed correct and when i updatet to 3.7.
# Update pyenv
mint@mint ~ $ pyenv update
  
# Look at what's available
mint@mint ~ $ pyenv install --list
Available versions:
....
3.6.6
  3.6.6rc1
  3.7.0
  3.7-dev
  3.8-dev
....
  
# Update needed
sudo apt-get update
sudo apt-get install libffi-dev
  
# Install 3.7
mint@mint ~ $ pyenv install 3.7.0
Installing Python-3.7.0...
Installed Python-3.7.0 to /home/mint/.pyenv/versions/3.7.0
  
# Set python and pip to point to 3.7
mint@mint ~ $ pyenv global 3.7.0
mint@mint ~ $ python -V
Python 3.7.0
mint@mint ~ $ pip -V
pip 10.0.1 from /home/mint/.pyenv/versions/3.7.0/lib/python3.7/site-packages/pip (python 3.7)
mint@mint ~ $ 
# Finish
This will be my last post about this Hand
If you can get someone to help you like live on PC that would be fine,
because you can not follow instruction given.
Quote
#18
This may be last help I ask. When I install python 3.7 with pyenv, it takes about 5 mn to upload, then at the install case, after about 3 mn it stops saying he can't install because "can't decompress data, zlib not available". If you have an idea please tell me.
Otherwise, to-morrow I will reread the huge information I have.
Quote
#19
@Dead_Eye Many many thanks. Now 3.7.0 is my default language. Problem solved , with your 3 lines:
apt install build-essential
apt-get install libssl-dev zlib1g-dev libncurses5-dev libncursesw5-dev libreadline-dev libsqlite3-dev
apt-get install libgdbm-dev libdb5.3-dev libbz2-dev libexpat1-dev liblzma-dev tk-dev
Quote
#20
This is good. I had the last week not much time to look.
My code examples are always for Python 3.x.
All humans together. We don't need politicians!
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Outlook] How to delete items from To-Do List? Winfried 1 72 Oct-19-2018, 09:05 PM
Last Post: nilamo
  Python files made on linux don't work on windows sylas 2 104 Oct-10-2018, 05:34 AM
Last Post: sylas
  delete pages in pdf according to bookmarks vagser 0 97 Sep-29-2018, 11:33 AM
Last Post: vagser
  Delete file with read-only permission, but write permission to parent folder cubei 4 331 Aug-28-2018, 09:40 AM
Last Post: cubei
  Methods of running a script on Linux distro Vysero 6 212 Aug-21-2018, 09:11 PM
Last Post: heras
  How yo find "zlib" necessary for "pyenv" in Linux sylas 1 218 Aug-13-2018, 10:27 AM
Last Post: Larz60+
  Problem in a python2 file sylas 15 390 Aug-08-2018, 08:54 AM
Last Post: sylas
  can import msvcrt and click on windows but not on Linux sylas 4 354 Aug-06-2018, 08:28 AM
Last Post: Gribouillis
  Compare element of list with line of file : if match, delete line silfer 4 349 Jul-21-2018, 02:44 PM
Last Post: silfer
  Beautiful Soup - Delete All HTML - Except Specific Classes dj99 7 462 Jul-13-2018, 08:18 AM
Last Post: dj99

Forum Jump:


Users browsing this thread: 1 Guest(s)