Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 syntax error near unexpected token
Hello! ultra noobie with all things programming and I am currently registered in an online python course. During the tutorials I got stuck when I was prompted to enter a line:

name="BRADY H".lower()
This happens in only Visual Studio Code

It is supposed to be an example of the various python functions you can use but when I use this or .upper() or .replace() or any of the other tutorial functions I keep getting the error

bash:syntax error near unexpected token `('
Also I have tried:

my_book="My favorite book is 'Tod Sawyer',".replace('Tod', 'Tom')
but get the same error...
This happens in both the editor (Visual Studio Code) and the shell/terminal on my computer. Please help as I am eager to learn but feel I can't even get started!
Yoriz wrote Apr-21-2019, 08:32 PM:
Please post all code, output and errors (in it's entirety) between their respective tags. I did it for you this time, Here are instructions on how to do it yourself next time.
Doesn't look like there is anything wrong with the code posted.
Could it have to do with the PATH when python was installed then? I'm sorry I wish I could give you more information but this is all I have to work with and why I am here on the forums. Also thank you for reformatting my question for me, my apologies.

Also when the functions are typed out in Visual studio code they do not change color to cyan, as illustrated in most tutorials. I don't think this would be the issue as the shell has no problem with it.
Your error starts with 'bash,' so you seem to be running the code in the bash shell rather than in Python. If it only happens in Visual Studio, I would guess you don't have Visual Studio set up correctly to run Python code. However, I am not familiar with Visual Studio, and would have no idea how to fix that.
Craig "Ichabod" O'Brien -
I wish you happiness.
Recommended Tutorials: BBCode, functions, classes, text adventures

Make sure you have the python extension installed
Thank you this information is very helpful. Hopefully it will give me enough to troubleshoot the issue through google. I have also verified that the python extension within VSC is installed and active

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  Syntax Error megearhart4 2 56 Oct-20-2019, 05:27 PM
Last Post: ichabod801
  kivy - packaging touchtracer syntax error cram 2 93 Oct-14-2019, 08:30 PM
Last Post: cram
  sqlite3.OperationalError: near "%": syntax error Linuxdesire 2 155 Oct-13-2019, 02:54 AM
Last Post: Linuxdesire
  def Display Data Invalid Syntax error Linuxdesire 1 92 Oct-11-2019, 05:10 AM
Last Post: stranac
  Invalid Syntax error mustfirst 8 154 Oct-07-2019, 06:39 PM
Last Post: buran
  get and reuse the token value with huawei modem Reims 1 116 Oct-02-2019, 04:29 AM
Last Post: Reims
  Syntax Error with Argument Parser aditya_man 1 100 Sep-30-2019, 01:21 PM
Last Post: ichabod801
  Need help with "unexpected expression syntax error" PyCoder 2 120 Sep-29-2019, 05:42 AM
Last Post: PyCoder
  Error Syntax -HackerRank challenge RavCOder 9 265 Sep-20-2019, 02:57 PM
Last Post: perfringo
Exclamation Get syntax error. Dont understand why beLIEve 21 1,147 Aug-25-2019, 02:28 PM
Last Post: ThomasL

Forum Jump:

Users browsing this thread: 2 Guest(s)