Python Forum
Cartopy Error - Printable Version

+- Python Forum (https://python-forum.io)
+-- Forum: Python Coding (https://python-forum.io/Forum-Python-Coding)
+--- Forum: General Coding Help (https://python-forum.io/Forum-General-Coding-Help)
+--- Thread: Cartopy Error (/Thread-Cartopy-Error)



Cartopy Error - bostonwx - Aug-09-2019

Good morning,

Before I get into my issue, I have extensively searched on google in hopes of finding a solution and I've found nothing. I'm also just sort of learning Python so my background isn't quite strong and I don't have a strong background with computer programming.

Essentially all I'm trying to do is install Cartopy and I've been numerous hours trying to figure this out.

1) When trying to install Cartopy through pip, it would flag back an error saying Proj 4 was needed.

2) I downloaded Conda and tried installing Cartopy that way. It worked, up until when it was loading shapefile (I think that's what it was) so I installed that and it appeared Cartopy worked through Conda.

3) I go back into python and try importing Cartopy and I receive a ModuleNotFoundError: No module named 'Cartopy"

I've searched and looked around and I have found nothing which has helped...part of the issue probably is my lack of background.

I'm sure I will need to provide more information and I would be happy to do so if needed.

Thank you


RE: Cartopy Error - Larz60+ - Aug-09-2019

Best to contact authors as they suggest a wheel (which I cannot find)
Authors contact: https://github.com/SciTools/cartopy


RE: Cartopy Error - bostonwx - Aug-09-2019

I'm guessing all I need to do is get Proj version 4. Within the error message when doing

pip install cartopy
It says

Proj version 0.0.0 is installed, but cartopy requires at least version 4.9.0

I've tried

pip install --update proj
that didn't work.


RE: Cartopy Error - Larz60+ - Aug-09-2019

capital P on proj
and command is:
pip install --upgrade Proj



RE: Cartopy Error - bostonwx - Aug-09-2019

(Aug-09-2019, 11:10 AM)Larz60+ Wrote: Best to contact authors as they suggest a wheel (which I cannot find)
Authors contact: https://github.com/SciTools/cartopy

Thank you for the reply.

This was something I did come across. I will look more into this and see how I need to utilize the information.


RE: Cartopy Error - Larz60+ - Aug-09-2019

See correction to my last post.
it's upgrade, not update, and 'P' not 'p'


RE: Cartopy Error - bostonwx - Aug-09-2019

(Aug-09-2019, 11:18 AM)Larz60+ Wrote: capital P on proj
and command is:
pip install --upgrade Proj

I made those corrections and ran it.
Came back with requirements already satisfied and skipping upgrade.

I tired installing Cartopy again and still saying Proj version 0.0.0 is installed

ughhh this has been so frustrating

One thing I have done as well is instead of using pip for Cartopy I downloaded Conda and through Anaconda I was able to install Proj4 and Cartopy. Both installed successfully here, however, I guess it isn't syncing with Python.