Python Forum
Installing pip packages on Windows 10 tablet
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installing pip packages on Windows 10 tablet
I have Python 3.7 installed on my Windows 10 PC and Windows tablet. On the PC, I am able to install pip packages using command prompt no problem. However, following the same approach on the tablet, the command runs without error but, after a short delay, does nothing and just returns a new line. I run as an administrator and am in the correct path folder.

Any ideas why this is not working?

What do you get if you run both python --version and pip --version?
python version is 3.7.0
pip --version does not return any result and I just get a new command line (as when I go to install a new package). I've copied the text from Command Prompt below to illustrate this.

C:\Users\vaqui\AppData\Local\Programs\Python\Python37-32>python --version
Python 3.7.0

C:\Users\vaqui\AppData\Local\Programs\Python\Python37-32>pip --version

C:\Users\vaqui\AppData\Local\Programs\Python\Python37-32>pip install numpy

Alright, let's try...
python -m ensurepip
And if that says something like "Requirement already satisfied", then let's try letting pip update itself:
python -m pip install --upgrade pip.
pip is in ...Python37-32\Scripts folder.
Cd into Script folder the try to install from there.
python --version work is because python.exe is in Python37-32 folder.

The reason that you have to be in right folder to run commands is because Environment variables is not set to point to Python and Scripts folder.
Don't know how it work on Tablet,can look here how to set on Window 10.
Thanks for the suggestions. I was running pip from the scripts folders, although I also tried copying it into the parent folder to see if this fixed it (hence the commands shown previously).

I've tried the fixes suggested and no luck.

{Edited format below - for avoidance of doubt the code relates to command prompt, not pythoon}

C:\Users\vaqui\AppData\Local\Programs\Python\Python37-32>python -m ensurepip
Looking in links: C:\Users\vaqui\AppData\Local\Temp\tmpiizryp7w
Requirement already satisfied: setuptools in c:\users\vaqui\appdata\local\programs\python\python37-32\lib\site-packages (39.0.1)
Requirement already satisfied: pip in c:\users\vaqui\appdata\local\programs\python\python37-32\lib\site-packages (18.1)

C:\Users\vaqui\AppData\Local\Programs\Python\Python37-32>python -m pip install --upgrade pip
Requirement already up-to-date: pip in c:\users\vaqui\appdata\local\programs\python\python37-32\lib\site-packages (18.1)


C:\Users\vaqui\AppData\Local\Programs\Python\Python37-32\Scripts>pip install numpy

C:\Users\vaqui\AppData\Local\Programs\Python\Python37-32\Scripts>pip --version


Possibly Related Threads…
Thread Author Replies Views Last Post
  installing anaconda packages offline HulkHogansArmsArePythons 4 2,584 Feb-18-2020, 08:23 PM
Last Post: jefsummers
  Installing packages through Anaconda? Athenaeum 5 12,952 Oct-08-2017, 03:17 AM
Last Post: Athenaeum

Forum Jump:

User Panel Messages

Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020