Python Forum
Installing auto-sklearn on Windows 10
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installing auto-sklearn on Windows 10
#1
I installed Ubuntu 18.04 on Windows 10 as an application. The latest version of python in Ubuntu 18.04 is python 3.6.9.

Since I wish to install and use auto-sklearn I must have python 3.7 or greater.

I created a virtual environment of Ubuntu 18.04 and added a second version of python or python 3.7.2. That should easily
install auto-sklearn. To make it easier, I aliased them

python to python3.7
and
python3 to python3.7. They are presently not permanent now, but I can make them permanent when I need to do so.

However, what about pip and pip3? They are both connected to the original python 3.6.9. That python version will not work.

To my understanding they must be associated with python 3.7.2. The only python version that can install auto-sklearn in my virtual environment is version 3.7.2 and that goes for pip and pip3, also.

The code below shows this.

Output:
(awesome_venv) [email protected]:~/awesome_python_project$ python -V Python 3.7.10 (awesome_venv) [email protected]:~/awesome_python_project$ python3 -V Python 3.7.10 (awesome_venv) [email protected]:~/awesome_python_project$ alias alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"' alias egrep='egrep --color=auto' alias fgrep='fgrep --color=auto' alias grep='grep --color=auto' alias l='ls -CF' alias la='ls -A' alias ll='ls -alF' alias ls='ls --color=auto' alias python='python3.7' alias python3='python3.7' (awesome_venv) [email protected]:~/awesome_python_project$ pip -V pip 9.0.1 from /home/james/awesome_python_project/awesome_venv/lib/python3.6/site-packages (python 3.6) (awesome_venv) [email protected]:~/awesome_python_project$ pip3 -V pip 9.0.1 from /home/james/awesome_python_project/awesome_venv/lib/python3.6/site-packages (python 3.6) (awesome_venv) [email protected]:~/awesome_python_project$
I need to connect pip3 and pip to python 3.7.2.

My questions is how do I do it?

Thanks in advance.

Respectfully,

LZ
Reply
#2
First I would want to see why the pip isn't being found via the environment set up. (Assuming you're running a bourne-like shell), what do you get when you run command -v pip and echo $PATH in the virtual environment?

Second, if you want a workaround, just run pip from python directly.
python -m pip -V
Since the correct python is being found, this should work.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Installing Qt for Python. (On Windows 10) davediamond 22 1,434 Apr-18-2022, 06:50 AM
Last Post: ndc85430
  Unable to import sklearn after installing any package ilango 0 729 Oct-25-2021, 07:03 AM
Last Post: ilango
  Index data must be 1-dimensional : Classifier with sklearn Salma 0 3,096 Apr-01-2021, 03:22 PM
Last Post: Salma
  Need help installing infoblox-client on Windows 10 dazmac10 1 1,757 Mar-07-2021, 10:57 PM
Last Post: snippsat
  error while installing any library using pip in windows AkashKansal 1 2,886 Sep-24-2020, 07:51 AM
Last Post: buran
  installing python in windows 10 martynarthur2102 1 1,093 Aug-22-2020, 01:53 PM
Last Post: buran
  Installing pip windows 10 jcg36 9 3,451 Sep-13-2019, 12:44 PM
Last Post: snippsat
  Fetching data from Sklearn zaki424160 2 3,306 Jul-09-2019, 05:20 AM
Last Post: ThomasL
  pip not installing any package on windows royhimo855 0 2,506 Dec-10-2018, 07:58 AM
Last Post: royhimo855
  Installing and running a python web scraping app from github to a windows 8.1 system eugenioca 17 6,028 Oct-06-2018, 08:14 AM
Last Post: eugenioca

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020