Python Forum
Request library already satisfied? Pip related
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Request library already satisfied? Pip related
#1
Apologies but this doesn't seem to fit in any other forum category. Maybe there's a dedicated PIP forum somewhere?

% python process.py 
You need the requests library to be installed in order to use this sample.
Run 'pip install requests' to fix it.
[email protected] abbyy % pip install requests                                                                                     
Requirement already satisfied: requests in /Users/j/Library/Python/3.9/lib/python/site-packages (2.25.1)
Requirement already satisfied: chardet<5,>=3.0.2 in /Users/j/Library/Python/3.9/lib/python/site-packages (from requests) (4.0.0)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /Users/j/Library/Python/3.9/lib/python/site-packages (from requests) (1.26.5)
Requirement already satisfied: idna<3,>=2.5 in /Users/j/Library/Python/3.9/lib/python/site-packages (from requests) (2.10)
Requirement already satisfied: certifi>=2017.4.17 in /Users/j/Library/Python/3.9/lib/python/site-packages (from requests) (2021.5.30)
WARNING: You are using pip version 21.1.2; however, version 21.1.3 is available.
You should consider upgrading via the '/Library/Frameworks/Python.framework/Versions/3.9/bin/python3 -m pip install --upgrade pip' command.
[email protected] abbyy % 
Reply
#2
try $ python3 process.py
I guess python is associated with python2.
If you can't explain it to a six year old, you don't understand it yourself, Albert Einstein
How to Ask Questions The Smart Way: link and another link
Create MCV example
Debug small programs

Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  how can I correct the Bad Request error on my curl request tomtom 8 2,453 Oct-03-2021, 06:32 AM
Last Post: tomtom
  Installed pip install openpyxl, Requirement already satisfied, but, still have error jonah88888 3 3,804 Sep-24-2021, 02:11 AM
Last Post: jonah88888
  Although this is a talib related Q it's mostly related to python module installing.. Evalias123 4 3,919 Jan-10-2021, 11:39 PM
Last Post: Evalias123
  ImportError: cannot import name 'Request' from 'request' abhishek81py 1 3,061 Jun-18-2020, 08:07 AM
Last Post: buran
  PyInstaller, how to create library folder instead of library.zip file ? harun2525 2 3,839 May-06-2017, 11:29 AM
Last Post: harun2525

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020