Python Forum
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Install error
#1
Dear all,

Do you have any solution to the following intall error:

yuan@yuan-virtual-machine:~/smplx$ sudo python3 setup.py install
[sudo] password for yuan:
running install
/usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
warnings.warn(
/usr/lib/python3/dist-packages/setuptools/command/easy_install.py:158: EasyInstallDeprecationWarning: easy_install command is deprecated. Use build and pip and other standards-based tools.
warnings.warn(
running bdist_egg
running egg_info
creating smplx.egg-info
writing smplx.egg-info/PKG-INFO
writing dependency_links to smplx.egg-info/dependency_links.txt
writing requirements to smplx.egg-info/requires.txt
writing top-level names to smplx.egg-info/top_level.txt
writing manifest file 'smplx.egg-info/SOURCES.txt'
reading manifest file 'smplx.egg-info/SOURCES.txt'
adding license file 'LICENSE'
writing manifest file 'smplx.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib
creating build/lib/smplx
copying smplx/lbs.py -> build/lib/smplx
copying smplx/vertex_ids.py -> build/lib/smplx
copying smplx/joint_names.py -> build/lib/smplx
copying smplx/__init__.py -> build/lib/smplx
copying smplx/body_models.py -> build/lib/smplx
copying smplx/vertex_joint_selector.py -> build/lib/smplx
copying smplx/utils.py -> build/lib/smplx
creating build/bdist.linux-x86_64
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/smplx
copying build/lib/smplx/lbs.py -> build/bdist.linux-x86_64/egg/smplx
copying build/lib/smplx/vertex_ids.py -> build/bdist.linux-x86_64/egg/smplx
copying build/lib/smplx/joint_names.py -> build/bdist.linux-x86_64/egg/smplx
copying build/lib/smplx/__init__.py -> build/bdist.linux-x86_64/egg/smplx
copying build/lib/smplx/body_models.py -> build/bdist.linux-x86_64/egg/smplx
copying build/lib/smplx/vertex_joint_selector.py -> build/bdist.linux-x86_64/egg/smplx
copying build/lib/smplx/utils.py -> build/bdist.linux-x86_64/egg/smplx
byte-compiling build/bdist.linux-x86_64/egg/smplx/lbs.py to lbs.cpython-310.pyc
byte-compiling build/bdist.linux-x86_64/egg/smplx/vertex_ids.py to vertex_ids.cpython-310.pyc
byte-compiling build/bdist.linux-x86_64/egg/smplx/joint_names.py to joint_names.cpython-310.pyc
byte-compiling build/bdist.linux-x86_64/egg/smplx/__init__.py to __init__.cpython-310.pyc
byte-compiling build/bdist.linux-x86_64/egg/smplx/body_models.py to body_models.cpython-310.pyc
byte-compiling build/bdist.linux-x86_64/egg/smplx/vertex_joint_selector.py to vertex_joint_selector.cpython-310.pyc
byte-compiling build/bdist.linux-x86_64/egg/smplx/utils.py to utils.cpython-310.pyc
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying smplx.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying smplx.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying smplx.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying smplx.egg-info/requires.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying smplx.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
creating dist
creating 'dist/smplx-0.1.28-py3.10.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing smplx-0.1.28-py3.10.egg
Copying smplx-0.1.28-py3.10.egg to /usr/local/lib/python3.10/dist-packages
Adding smplx 0.1.28 to easy-install.pth file

Installed /usr/local/lib/python3.10/dist-packages/smplx-0.1.28-py3.10.egg
Processing dependencies for smplx==0.1.28
Searching for torch>=1.0.1.post2
Reading https://pypi.org/simple/torch/
Download error on https://pypi.org/simple/torch/: [Errno -3] Temporary failure in name resolution -- Some packages may not be found!
Couldn't find index page for 'torch' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -3] Temporary failure in name resolution -- Some packages may not be found!
No local packages or working download links found for torch>=1.0.1.post2
error: Could not find suitable distribution for Requirement.parse('torch>=1.0.1.post2')



Many thanks. Yuan
Reply
#2
Solved. Thanks.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  wxPython install error carlomscalisi 3 3,737 Jan-17-2023, 11:04 AM
Last Post: snippsat
  Error with pip install coffeeguy 1 2,433 Sep-08-2022, 01:27 AM
Last Post: snippsat
  kmeans install error (please help me) muratuzun 3 5,791 May-06-2022, 02:14 PM
Last Post: snippsat
  Install any library via pip get an error cannot import name 'SCHEME_KEYS' from 'pip. Anldra12 2 10,830 Jan-04-2022, 01:05 PM
Last Post: Anldra12
  Anaconda pip install mpyc Error pip-script.py is not present Anldra12 2 7,972 Dec-13-2021, 06:59 PM
Last Post: Anldra12
  Minecraft Python install error SomeAcandKid 1 2,404 Oct-06-2021, 06:22 PM
Last Post: Ronhamas
  Installed pip install openpyxl, Requirement already satisfied, but, still have error jonah88888 3 6,840 Sep-24-2021, 02:11 AM
Last Post: jonah88888
  error trying to install sslstrip NullAdmin 1 4,124 Mar-11-2021, 09:37 PM
Last Post: buran
  python setup.py install error blackclover 2 8,071 Jan-07-2021, 04:36 AM
Last Post: blackclover
  trying to pip install stasm module getting error djf123 3 4,580 Jul-26-2020, 05:00 AM
Last Post: millpond

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020