Python Forum
Installing Error - Python 2.7.8
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installing Error - Python 2.7.8
#1
Hi hi!

I'm trying to teach myself python using a somewhat outdated book. Im just going through it to get a handle on some of the basics but this book in particular requires Python version 2.7.8. I have followed the installation instructions but I am receiving an error message: "The installer could not install the software because there was no software found to install".

I have not been able to find a solution to this error message online.

I am running Mac OS High Sierra.

I have seen online that some are suggesting to install specifically using the python installer, and ensuring that the python installer is used by right clicking and manually selecting it. I have already done this as well.

Any help would be appreciated. Thanks!
Reply
#2
Python 2.7 is no longer supported so I am curious why you would be trying to learn python with outdated material and writing methods?
You should be attempting to learn Python 3.x
Reply
#3
  • Python 2 isn't supported anymore, please install python 3
  • Even if you are trying to install python 2, it might be the version of your macOS which results in an error - you are still using High sierra. Check your system for updates
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  error while installing any library using pip in windows AkashKansal 1 276 Sep-24-2020, 07:51 AM
Last Post: buran
  Pip prints huge error when installing p5 hayden2s 1 300 Aug-08-2020, 02:30 PM
Last Post: snippsat
  Getting error while installing packages using pip Shreya 2 623 Apr-22-2020, 08:03 AM
Last Post: Shreya
  Error Installing PySceneDetect and OpenCV jpnoli 1 385 Mar-26-2020, 12:19 PM
Last Post: buran
  Error after installing Python3.8.2: "No module named 'apt_pkg'" Chromie 3 1,509 Mar-09-2020, 08:20 PM
Last Post: micseydel
  error in installing Pystan sveto4ka 6 1,158 Oct-06-2019, 06:25 PM
Last Post: sveto4ka
  Error in VS Code after installing raduf 2 1,272 Dec-06-2018, 09:56 PM
Last Post: snippsat
  Error when installing module tjnichols 2 2,798 May-13-2018, 04:51 PM
Last Post: tjnichols
  Fix Memory Error while installing a library for Qgis alexastorga 0 1,191 Apr-13-2018, 04:54 PM
Last Post: alexastorga
  Ubuntu: Error installing watson-developer-cloud Python module gio123 3 2,186 Mar-15-2018, 09:39 PM
Last Post: gio123

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020