Bottom Page

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Virtualenv and an infinitely spooling interpreter?
#1
Hi,

I have just started trying to tentatively dip a toe into Python, and have hit a wall when it comes to getting a virtualenv to create, rather than doing so, it is giving me an infinitely spooling interpreter text!

I have used pip to install virtualenv, and that seems to have worked fine, but the following screenshots show what happens after...

What I'm doing....
İmage


1st response type
İmage


2nd response type
İmage


The spooling goes on for quite a long time, it has been crashing out entirely, but the debug is new today.

I have spent about 14 hours over the past two days trying to work out why it isn't playing ball. I've uninstalled and reinstalled Python 8 times, moving it around and out of my program files and directly onto C:\ (in case the space in 'program files (x82) was tripping it up!), I've tried installing as an administrator and not, tried installing 32bit and 64bit versions, and tried installing a previous version. In my past round of this, I uninstalled, and went through my computer deleting anything that involved python or pip at all (even the rogue wild files that were living native many layers deep!), and ran ccleaner a handful of times to mop up everything. Mostly I've been trying 64bit Python v3.7.4, which is what I'm running at the moment, and I'm running up-to-date Windows10.

I've tried googling, but either this is weird enough to be novel, or my newbie nature means I'm not searching the right terminology so I'm not finding anything. Having asked anyone I can think of, and still having no dice, I'm officially stuck - apparently this is 'weird'!

I was wondering if anyone might be able to suggest something to fix it? Thank you so much in advance!
Quote
#2
can you create one using:
python -m venv myvirtualenv
?
Quote
#3
As mention over use the build in venv,to make virtual environment.
None of your picture link works.

Basic install Python 3.6/3.7 and pip installation under Windows.
From start all in done in cmd,i use cmder daily and not cmd.
# Check python version
E:\div_code>python -V
Python 3.7.3

# Check pip
E:\div_code>pip -V
pip 19.1.1 from c:\python37\lib\site-packages\pip (python 3.7)

# Make virtual environment
E:\div_code>python -m venv my_env

# Cd in
E:\div_code>cd my_env

# Activate environment, see after (my_env)  
E:\div_code\my_env>E:\div_code\my_env\Scripts\Activate

# Check pip again,see now that in point to my_env folder
(my_env) E:\div_code\my_env>pip -V
pip 19.0.3 from e:\div_code\my_env\lib\site-packages\pip (python 3.7)

# Will now only install into environment
(my_env) E:\div_code\my_env>pip install requests
Collecting requests .....
Installing collected packages: chardet, certifi, urllib3, idna, requests
Successfully installed certifi-2019.6.16 chardet-3.0.4 idna-2.8 requests-2.22.0 urllib3-1.25.3


# Test that it work
my_env) E:\div_code\my_env>python
Python 3.7.3 (v3.7.3:ef4ec6ed12, Mar 25 2019, 21:26:53) [MSC v.1916 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import requessts
>>>
>>> requests.__version__
'2.22.0'
>>> exit()
See also this where i explain some more.
Quote
#4
(Jul-11-2019, 10:29 AM)Larz60+ Wrote: can you create one using:
python -m venv myvirtualenv
?

Not sure why mine wasn't working, but this worked! Thank you so much! I've checked, and it activates perfect too.

Just for my own curiosity, the "-m" stands for make? Or something else?

Again, thank you!

I've gone through the rest by Snippsat...
(venv) F:\muddev\venv>pip -V
pip 19.1.1 from f:\muddev\venv\lib\site-packages\pip (python 3.7)
Installing collected packages: chardet, certifi, urllib3, idna, requests
Successfully installed certifi-2019.6.16 chardet-3.0.4 idna-2.8 requests-2.22.0 urllib3-1.25.3
>>> import requests
>>>
>>> requests.__version__
'2.22.0'
>>> exit()
So I've got a different number for my pip version from pip -V, but I'm guessing a later version is not an issue?

Just so pleased to actually be moving forwards once more :)
Quote

Top Page

Possibly Related Threads...
Thread Author Replies Views Last Post
  Installing PIP and setting up virtualenv steveholland68 1 258 Aug-08-2019, 05:52 PM
Last Post: snippsat
  python -m venv VS virtualenv kazi380 4 346 Jul-17-2019, 08:51 PM
Last Post: Larz60+
  Why is virtualenv not by default relocatable? bpostow 1 374 Mar-08-2019, 06:57 PM
Last Post: bpostow
  opencv without virtualenv tony1812 0 1,280 Jan-20-2018, 12:42 AM
Last Post: tony1812
  virtualenv activate.ps1 hash error po20 2 1,145 Jan-13-2018, 09:21 AM
Last Post: po20
  virtualenv on powershell mcmxl22 3 2,527 Feb-08-2017, 06:29 AM
Last Post: snippsat

Forum Jump:


Users browsing this thread: 1 Guest(s)