Python Forum
ImportError: No module named pydrive.auth
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ImportError: No module named pydrive.auth
#1
Hi all,

I am new to python and looking for some advice on the following error

ImportError: No module named pydrive.auth

What would I need to do to correct this error? I am using Terminal on a macbook.
Reply
#2
did you install PyDrive?
https://pythonhosted.org/PyDrive/

$ pip install PyDrive
If you can't explain it to a six year old, you don't understand it yourself, Albert Einstein
How to Ask Questions The Smart Way: link and another link
Create MCV example
Debug small programs

Reply
#3
To add to buran's post, I tend to do pythonversion -m pip install module eg(python3.8.2 -m pip install PyDrive). That way I know I'm installing for the version of python I'm using.
I welcome all feedback.
The only dumb question, is one that doesn't get asked.
Gaming Collection
Homepage
my-python
Reply
#4
(Jun-23-2020, 05:20 PM)menator01 Wrote: To add to buran's post, I tend to do pythonversion -m pip install module eg(python3.8.2 -m pip install PyDrive). That way I know I'm installing for the version of python I'm using.

What command do i type into terminal for this ?

I've typed in pip install PyDrive and getting a lot of error message.

This is one of them Installing build dependencies ... error
ERROR: Command errored out with exit status 1

I tend to do pythonversion -m pip install module eg(python3.8.2 -m pip install PyDrive)

What command do i type first ? Or just copy and paste this pythonversion -m pip install module eg(python3.8.2 -m pip install PyDrive)

also I have installed the latest python version on my mac but when I type in the following command python --version it shows that I have a version Python 2.7.16 why could this be?
Reply
#5
python3.8 -m pip install PyDrive

You may want to check spelling pydrive may be caps and may not. I haven't used it

Pypi website is here
I welcome all feedback.
The only dumb question, is one that doesn't get asked.
Gaming Collection
Homepage
my-python
Reply
#6
(Jun-23-2020, 05:49 PM)lknights1987 Wrote: also I have installed the latest python version on my mac but when I type in the following command python --version it shows that I have a version Python 2.7.16 why could this be?
You most try with:
python3 --version
pip3 --version
It should at least point to python 3.7 or newer.
Python 2.7.16 is default version that comes with your mac version,and should not be used anymore.

Install Python 3 on MacOS
If pip3 is in path only this is needed.
pip3 install PyDrive
This is just the same:
python3 -m pip install PyDrive
Now work as this -m run library module as a script,so can work also if pip3 in not path,
but pip3 should be in Path of OS.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  ModuleNotFoundError: No module named 'Seal' Anldra12 10 458 Oct-06-2021, 12:12 PM
Last Post: snippsat
  ModuleNotFoundError: No module named 'bluetooth' Error Rovelin 4 523 Aug-31-2021, 04:04 PM
Last Post: Rovelin
  No module named 'pysolar' - even tough pysolar is installed - What am I doing wrong? Jghurt 5 944 May-08-2021, 07:03 PM
Last Post: Jghurt
  IBM Watson: Handshake status 403 Forbidden or No section: 'auth' groschat 1 1,000 May-07-2021, 03:44 PM
Last Post: jefsummers
  ModuleNotFoundError: No module named 'graph' Anldra12 3 1,764 May-02-2021, 02:41 PM
Last Post: Anldra12
  ModuleNotFoundError: No module named 'fpdf' KatMac 4 2,134 Apr-19-2021, 01:23 PM
Last Post: KatMac
  ModuleNotFoundError: No module named 'com' aleksg 9 2,905 Dec-14-2020, 05:00 PM
Last Post: Larz60+
Video ModuleNotFoundError: No module named ‘…’ Frank911 1 1,674 Dec-11-2020, 03:59 PM
Last Post: michael1789
  no module named finbert found ErnestTBass 4 1,449 Dec-05-2020, 06:09 PM
Last Post: andrianas
  ModuleNotFoundError: No module named 'fcntl' ErnestTBass 2 7,015 Dec-05-2020, 02:39 PM
Last Post: ErnestTBass

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020