Python Forum
error : "Microsoft Visual C++ 14.0 is required. " Even its installed
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error : "Microsoft Visual C++ 14.0 is required. " Even its installed
#1
Hi

just started using pycharm
I fail to install libraries and get this error
is something missing in my system ?

I use Win 10

thank you!

Error:
Microsoft Visual C++ 14.0 is required. Get it with "Build Tools for Visual Studio": https://visualstudio.microsoft.com/downloads/ ---------------------------------------- ERROR: Command errored out with exit status 1: 'c:\users\barak\pycharmprojects\pythonproject3\venv\scripts\python.exe' -u -c 'import sys, setuptools, token ize; sys.argv[0] = '"'"'C:\\Users\\Barak\\AppData\\Local\\Temp\\pip-install-t2q3ajet\\twisted\\setup.py'"'"'; __file__='"'"'C:\\Users\\Barak\\AppData\\Loca l\\Temp\\pip-install-t2q3ajet\\twisted\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'" ');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\Barak\AppData\Local\Temp\pip-record-hr65a3kq\install-record.txt' --s ingle-version-externally-managed --compile --install-headers 'c:\users\barak\pycharmprojects\pythonproject3\venv\include\site\python3.8\twisted' Check the logs for full command output.
Reply
#2
You get this message when it try to compile a package.
Bye using wheel as we talk about in Thread then it do not need to compile.
Now you run in virtual environment pythonproject3\venv\,then need to have Twisted install in that environment for Scrapy to work.
Look at Configure a Python interpreter and choose a interpreter where you have install Scrapy to.

So Twisted is a package that not have fixes that it get the wheel automatic,but it try to compile on Windows.
That's why we did step to install wheel manually as in your other Thread.
To compile can be somewhat difficult setup process on Windows,that's why we use wheel for this.
Reply
#3
Hi
so if I understand correctly I need to download and install : Twisted-20.3.0-cp38-cp38-win_amd64.whl (download to the project folder)
and then try pip install scrapy ?
Reply
#4
No can use version you already installed Scrapy to in your other thread also Python 3.8 and not in a virtual environment.
Now you running from,venv means that this is a virtual environment.
c:\users\barak\pycharmprojects\pythonproject3\venv\scripts\python.exe
Go into Configure a Python interpreter and choose Python 3.8 in this Path.
C:\Users\Barak\AppData\Local\Microsoft\WindowsApps\PythonSoftwareFoundation.Python.3.8_qbz5n2kfra8p0\python.exe
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Error in code tensorflow is installed ErnestTBass 5 2,640 Nov-04-2020, 03:43 PM
Last Post: snippsat
  Creating Excel files compatible with microsoft access vkallavi 0 554 Sep-17-2020, 06:57 PM
Last Post: vkallavi
  how to solve "a bytes-like object is required, not 'str'" error maiya 2 941 Jul-28-2020, 07:03 PM
Last Post: bowlofred
  Authentication error when accessing Microsoft SharePoint klllmmm 3 3,029 Jun-10-2020, 07:46 AM
Last Post: nuffink
  Trying to install Pyquil, says I need Microsoft Visual C++ Groucho 10 2,024 Feb-18-2020, 05:46 PM
Last Post: snippsat
  2 Microsoft word Docx content comparison vintysaw 2 2,294 Oct-17-2019, 10:41 AM
Last Post: vintysaw
  In Visual Studio Python is not properly installed jalea148 4 1,296 Sep-26-2019, 12:31 PM
Last Post: snippsat
  authentication required error with urlopen Ranjirock 2 1,080 Sep-11-2019, 01:01 PM
Last Post: Ranjirock
  Type error: dump() missing 1 required positional argument: fp jaycuff13 2 11,437 Jul-13-2019, 10:21 AM
Last Post: jaycuff13
  missing 1 required positional argument error nikos 3 4,473 Feb-28-2019, 12:53 PM
Last Post: nikos

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020