Python Forum
“NameError” “is not defined” script that I know works on other computers
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
“NameError” “is not defined” script that I know works on other computers
#1
This question isn't that much about coding since the scripts seem to work on Win10. I only have troubles trying to run them on my mac. Some background: I installed some Python versions earlier when I tried to learn some basic coding but after getting errors running these scripts I uninstalled everything (except osx-included 2.7.16) But I still got the same outcome. Here are some links to the scripts/apps:

https://github.com/corpnewt/ProperTree

https://github.com/corpnewt/CPUFriendFriend

I know the ProperTree uses Tkinter but executing the .command this is all I get.

Error:
Last login: Mon Nov 23 16:33:08 on ttys000 /Volumes/\[Storage\]/OSX\ FIX/ProperTree-master/ProperTree.command ; exit; [email protected] ~ % /Volumes/\[Storage\]/OSX\ FIX/ProperTree-master/ProperTree.command ; exit; DEPRECATION WARNING: The system version of Tk is deprecated and may be removed in a future release. Please don't rely on it. Set TK_SILENCE_DEPRECATION=1 to suppress this warning. Exception in Tkinter callback Traceback (most recent call last): File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk/Tkinter.py", line 1547, in __call__ return self.func(*args) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk/Tkinter.py", line 596, in callit func(*args) File "/Volumes/[Storage]/OSX FIX/ProperTree-master/ProperTree.command", line 206, in <lambda> self.tk.after(250, lambda:self.check_open(plists)) File "/Volumes/[Storage]/OSX FIX/ProperTree-master/ProperTree.command", line 244, in check_open self.start_window = self.new_plist() File "/Volumes/[Storage]/OSX FIX/ProperTree-master/ProperTree.command", line 484, in new_plist window = plistwindow.PlistWindow(self, self.tk) NameError: global name 'plistwindow' is not defined
CPUFriendsFriend.command and get similar error:

Error:
Traceback (most recent call last): File "/Volumes/[Storage]/OSX FIX/CPUFriendFriend-master/CPUFriendFriend.py", line 338, in <module> c = CPUFF() File "/Volumes/[Storage]/OSX FIX/CPUFriendFriend-master/CPUFriendFriend.py", line 7, in __init__ self.u = utils.Utils("CPUFriendFriend") NameError: name 'utils' is not defined [Process completed]
Could it be a problem with the installation Python/Tkinter ?

I tried google "nameError: global name is not defined"... and directs me to different coding forums where people having problems with their scripts... But I hardly think that the coders of ProperTree, CPUFriendFriend done anything wrong... I would be very thankful for any help. Oh I'm on Catalina 10.15.7 by the way. Thanks
Larz60+ write Nov-24-2020, 04:49 PM:
Changed 'quote' tags to 'error' tags.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NameError: name 'u1' is not defined (on parser code Python) Melcu54 1 82 Yesterday, 04:36 PM
Last Post: snippsat
  script with imports works but pytest gives "ModuleNotFoundError"? Hpao 0 199 Jun-27-2021, 08:30 PM
Last Post: Hpao
  I am getting a NameError that is not defined and not sure why it happen rick0922 5 373 Jun-14-2021, 03:41 PM
Last Post: deanhystad
  [split] NameError: name 'start_with_first_selected' is not defined knoxvilles_joker 4 572 Apr-18-2021, 07:59 PM
Last Post: knoxvilles_joker
  NameError: name 'L2' is not defined soshelby 5 950 Nov-05-2020, 08:50 PM
Last Post: soshelby
  NameError: name 'target_id' is not defined bhagyashree 7 894 Nov-03-2020, 10:22 AM
Last Post: bhagyashree
  code not working, NameError: name 's' is not defined ridgerunnersjw 4 1,026 Oct-05-2020, 07:03 PM
Last Post: buran
  Going thru tutorials..."NameError: name 'raw_input' is not defined" hmonnier 4 1,134 Jul-14-2020, 02:19 PM
Last Post: BitPythoner
  NameError: name 'pins' is not defined glennford49 2 1,576 Jun-15-2020, 12:20 PM
Last Post: glennford49
  python library not defined in user defined function johnEmScott 2 846 May-30-2020, 04:14 AM
Last Post: DT2000

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020