Python Forum
ModuleNotFoundError: No module named 'Seal'
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ModuleNotFoundError: No module named 'Seal'
#1
I run project for Homographic Encryption Where Microsoft Seal library is needed as i run it from git and install successfully. But i am using Python3.8 I don't know why its not install how i install in Python3.8. I spent my time but it give me an error. Needed your suggestion
pip install seal
Seal pip install Error
Error:
Collecting seal Using cached seal-0.4.0-rc2.tar.gz (3.9 MB) ERROR: Command errored out with exit status 1: command: 'c:\users\dell\pycharmprojects\tree1\venv\scripts\python.exe' -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\dell\\AppData\\Lo cal\\Temp\\pip-install-wqhnys2c\\seal_121310caff9b4ea58a5e5b71c2cc6db2\\setup.py'"'"'; __file__='"'"'C:\\Users\\dell\\AppData\\Local\\Temp\\pip-install-wqhnys2c\\seal_12 1310caff9b4ea58a5e5b71c2cc6db2\\setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools imp ort setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base 'C:\Users\del l\AppData\Local\Temp\pip-pip-egg-info-bgmlkshd' cwd: C:\Users\dell\AppData\Local\Temp\pip-install-wqhnys2c\seal_121310caff9b4ea58a5e5b71c2cc6db2\ Complete output (9 lines): Traceback (most recent call last): File "<string>", line 1, in <module> File "C:\Users\dell\AppData\Local\Temp\pip-install-wqhnys2c\seal_121310caff9b4ea58a5e5b71c2cc6db2\setup.py", line 313, in <module> check_python_version() File "C:\Users\dell\AppData\Local\Temp\pip-install-wqhnys2c\seal_121310caff9b4ea58a5e5b71c2cc6db2\setup.py", line 58, in check_python_version override = ("true" == get_arg("override_version_check")) File "C:\Users\dell\AppData\Local\Temp\pip-install-wqhnys2c\seal_121310caff9b4ea58a5e5b71c2cc6db2\setup.py", line 47, in get_arg for i in xrange(len(sys.argv)): NameError: name 'xrange' is not defined ---------------------------------------- WARNING: Discarding https://files.pythonhosted.org/packages/7e/b7/9b3e77d7a04461b3b7a281d1987dca24a516888d62614454016205ada3b3/seal-0.4.0-rc2.tar.gz#sha256=76ecda1a41d76 836531fa135d72411696853d9a541e1faa8d0168eff91701da0 (from https://pypi.org/simple/seal/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. ERROR: Could not find a version that satisfies the requirement seal (from versions: devel-20120307, 0.4.0rc2) ERROR: No matching distribution found for seal
Code run Error
Error:
Traceback (most recent call last): File "D:\Python3.8.0\Python\lib\unittest\loader.py", line 34, in testFailure raise self._exception ImportError: Failed to import test module: Seal Traceback (most recent call last): File "D:\Python3.8.0\Python\lib\unittest\loader.py", line 154, in loadTestsFromName module = __import__(module_name) ModuleNotFoundError: No module named 'Seal'
Reply
#2
(Oct-03-2021, 04:24 AM)Anldra12 Wrote: pip install seal
That's this which is a old Python 2 library and wrong one.

Most follow this and build it using Visual Studio 2019
Or docker that may be the easiest option.
Reply
#3
@snippsat Thanks you using docker how it can be done by using in python. because i never used docker
Reply
#4
@snippsat i solved the problem to connect seal with Visual studio but do you know apply seal we can only run our codes in Visual or pycharm because pycharm is not working apply seal that can only connect with Visual studio
Reply
#5
I don't know what you mean bye connect with Visual studio.
In install so Visual Studio used to build it for Python.
When do this python setup.py build_ext -i you build it for your version of Python.
Also your main version from command line python -V
E:\
λ python -V
Python 3.9.5

E:\
λ python -c "import shutil;print(shutil.which('python'))"
C:\python39\python.EXE
When build this version can be used in PyCharm or VS Code.
Reply
#6
yeah but i have done seal by using this video tutorial https://www.youtube.com/watch?v=oZQ_c89HFU0
Reply
#7
That's video is the C++ installation using Visual studio.
If want to use from Python as linked before in Thread Microsoft SEAL For Python
Then you also use Visual studio,but now as a tool to build it for usage in Python.
After you have donewhat described here,it's build for Python and do not need need Visual studio anymore.
Now can use from PyChram,VS Code or plain Python from command line.
Reply
#8
Thanks you for your nice suggestion i have done in python too but for python the final option -----> python3 setup.py build_ext -i is not working for me.
Please give me suggestion How can i run this command because i run this same copy + paste and run in git command so its output as no external and internal command.
Reply
#9
(Oct-04-2021, 10:24 AM)Anldra12 Wrote: i have done in python too but for python the final option -----> python3 setup.py build_ext -i is not working for me
You are on Windows now you run command for Linux,it's python no 3.
Windows
python setup.py build_ext -i
Reply
#10
appreciated I have done but this command not execute python setup.py build_ext -i
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  'no module named' when creating packages mbastida 4 169 Nov-30-2021, 10:43 AM
Last Post: Gribouillis
Question Setuptools CLI program ModuleNotFoundError after splitting up module into package Postbote 1 172 Nov-25-2021, 06:35 PM
Last Post: Postbote
  No module named '_cffi_backend' error with executable not with python script stephanh 2 221 Nov-25-2021, 06:52 AM
Last Post: stephanh
  ModuleNotFoundError: No module named 'bluetooth' Error Rovelin 4 1,064 Aug-31-2021, 04:04 PM
Last Post: Rovelin
  No module named 'pysolar' - even tough pysolar is installed - What am I doing wrong? Jghurt 5 1,238 May-08-2021, 07:03 PM
Last Post: Jghurt
  ModuleNotFoundError: No module named 'graph' Anldra12 3 2,393 May-02-2021, 02:41 PM
Last Post: Anldra12
  ModuleNotFoundError: No module named 'fpdf' KatMac 4 2,700 Apr-19-2021, 01:23 PM
Last Post: KatMac
  ModuleNotFoundError: No module named 'com' aleksg 9 3,468 Dec-14-2020, 05:00 PM
Last Post: Larz60+
Video ModuleNotFoundError: No module named ‘…’ Frank911 1 2,029 Dec-11-2020, 03:59 PM
Last Post: michael1789
  no module named finbert found ErnestTBass 4 1,750 Dec-05-2020, 06:09 PM
Last Post: andrianas

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020