Python Forum
how to install numpy and matplotlib to Tkinter
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
how to install numpy and matplotlib to Tkinter
#1
Installed Tkinter-Python IDE and worked well on examples

I have Python 3.6 installed with working numpy matplotlib installation
I used: python -m install --users ........
tkinter does not recognize these instalations?

how to install again numpy and matplotlib in order to be recognized by
tkinter ?
PIP did not work any both cases?
Reply
#2
1. What system you on ?

2. Make sure you use admin/sudo pip install. Else pip doesn't have permission.
99 percent of computer problems exists between chair and keyboard.
Reply
#3
(Dec-02-2017, 01:26 PM)elwolv Wrote: I have Python 3.6 installed with working numpy matplotlib installation

If they are working, you only need to import them into your project.
If it ain't broke, I just haven't gotten to it yet.
OS: Windows 10, openSuse 42.3, freeBSD 11, Raspian "Stretch"
Python 3.6.5, IDE: PyCharm 2018 Community Edition
Reply
#4
sounds like a path problem. Start python from terminal window and see which version is running.
If it's showing 3.6, exit python and type: 'pip list' and make sure you see numpy and matplotlib in the installed module list.
Reply
#5
On my Mint 18.2 there 2 versions of pip:
pip is for python 2.x and pip3 for python 3.x
So if you are running python 3.x you need to use the pip3 installer otherwise you get the python 2.x versions which are only seen by python 2.x and usable by it.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Tkinter Matplotlib Nepo 1 849 Sep-27-2020, 10:20 AM
Last Post: Gribouillis
  Tkinter & matplotlib PillyChepper 9 1,971 Nov-23-2019, 10:36 AM
Last Post: PillyChepper
  Making a Matplotlib in Tkinter using a slider Jemeronimo 1 2,721 Dec-05-2018, 08:06 AM
Last Post: Gribouillis

Forum Jump:

User Panel Messages

Announcements
Announcement #1 8/1/2020
Announcement #2 8/2/2020
Announcement #3 8/6/2020